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ReFaMo Software Manual   V3.0.097 (Windows XP / Vista / Server 2003 & 2008 - 32bit&64bit) 
 
ReFaMo is a utility to monitor the performance of a cluster of systems in a quick & accessible format, and to allow 
access to each via Remote Desktop Protocol and VNC.  It also allows the remote startup, restart or shutdown of a 
system, and the remote execution of commands. 
 The software consists of two parts.  The first part is the Monitor Application (ReFaMo3.exe) that runs on the 
desktop and provides feedback on the monitored systems.  The second is the Node Application (ReFaMo Node.exe) 
that runs on each monitored system and allows it to be viewed in the Monitor application. 
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System Requirements and Specifications  
 
Windows: 
�  XP (32bit & 64bit) / Vista (32bit or 64bit) / Server 2003 -2008 (32bit or 64bit) 
�  1 GHz Intel® Pentium® 4 processor, Athlon AMD or better. 
�  10 MB available hard disk space for installation and documentation. 
�  256 Mb RAM minimum. 1 Gb of RAM memory recommended. 
 
 
Installation (Windows XP / XP64bit):  
 
After you have completed your order you should have received within 24hrs the latest version of the software in a .zip 
format. If you have not received it please contact Ixor (info3d@ixor3d.com)  
There is not really an installation. You just need to unzip / extract the refamo.zip files into your l ocal hard drive 
(not network hard drive).  In case you are not sure , please follow the instructions. 
 
1. Make a new folder and name it “ReFaMo” inside your local Hard Drive for example: C:\ReFaMo 
2. Unzip the ReFaMo.zip inside the folder you have just created. You should have something like this:  
 

      
 
 
Copy the “ReFaMo Node.exe”  to your Startup directory and run it.  
 
�  This will enable auto startup. A small “Loading…” window will appear. After 10 seconds, automatically it will 
disappear and you will notice a small icon at your system tray. This indicates that this node / PC is available for 
monitoring and control.  
�  Depending on your firewall settings, you need to allow the pop-up window. Press “Unblock”. 
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3. It is now time to run “ReFaMo.exe”.  
����  Again, depending on your firewall settings, you need to unblock ReFaMo3 the pop-up window.  

 

     
 
 
4. The software will run on Trial / Demo mode for 15 days until you register. In order to register your license you need 
to go: Help > About and click on the "Registration Request" button.  
5. Please fill out the Refamo 3 Registration Form  (Name, Address, Tel & Email) and click the Generate Registration 
File. Then e-mail your Refamo.RRQ  file to info3d@ixor3d.com. 
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Please setup on all machines / nodes a user password. It is convenient to have the same username and password on all 
nodes.  

 
�  Windows XP Start Menu:  Start > Control Panel > User Accounts > Computer Administrator Account > Create 

Password Change my password (if you have already one). 
�  Windows XP Classic Start Menu:  Start > Settings > Control Panel > User Accounts > Computer Administrator 

Account > Create Password or Change my password (if you have already one). 
 

       
 
After you have setup the User password you can disable the Windows login screen: 
�  Start > Run and type “control userpasswords2” and click OK. 
�  Remove “Users must enter a user name and password to use this computer” then click Apply and OK. 
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User Interface - File Menu 
 
File >  Add System(s): You can simply type the IP number or specify the IP range. (e.g. 192.168.1.100) 
File >  Add Group: Opens a window where you can type a Group Name (e.g. Workstations, Servers, etc.) 
File >  Upgrade Nodes...: (Refamo will Auto-detect and request to Press the "Upgrade Nodes") 
File >  Quit (Ctrl+Q) 
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User Interface - Selected Menu 
 
Selected > Remote Command... 
Selected > Wake (Ctrl+Shift+W): The selected machines based on Groups or Individual Selection will Turn ON. Please 
note that this action might take 1-2 minutes to appear online since Windows take some time to load. Make sure the 
Refamo Node.exe is in your Start Up folder! 
Selected >  Restart (Ctrl+Shift+R): The selected machines based on Groups or Individual Selection will Reboot. 
Selected >  Shutdown (Ctrl+Shift+S): The selected machines based on Groups or Individual Selection will Turn OFF. 
Refamo will instantly close the connections and the machines will appear off. Please make sure the first time that you 
run this action, that the selected systems are indeed switched-off. Of course again wait 1-3minitues since Windows 

might take some time...    
This option will dramatically reduce your electricity bill - especially when use with the Energy Option. see page -8- 
 
Selected > Move Machines To...: The selected machines based on Groups or Individual Selection will be moved inside 
a Group that you have created from the File Menu. (see page 5) 
Selected > Delete (Ctrl+Shift+D) : The selected machines based on Groups or Individual Selection will be deleted!  

Note: You can not Undo this action! 
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User Interface - Window Menu 
 
Window > Hide / Show Graph Panel (Ctrl+G): At the bottom of Refamo UI a Graph Panel can be added. Users have 
the option to turn off the visibility of the graphs of different counters. (CPU%, Memory%, Disk %, Disk IO, Network IO).  

Note: The Graph Panel will always show the highlighted Group or Node average values.  
Note: CPU% will show the average value of all the CPUs available. For example on a Quad-Core System, it will show 

the average load of the 4 CPUs.  
Window > Show / Hide Find Box (Ctrl+F): At the top right of Refamo UI a Find Box will appear. You can type the 
System Name or IP address for faster selection. 
Window > Auto Size Window (Ctrl+A) 
Window > Display Borderless (Ctrl+B) 
Window > Display Full Screen (Ctrl+Enter) 
Window > Appearance > Opacity: 4 Opacity levels are available. 100% (no opacity) – 75% – 50% and 25% Opacity. 
Window > Appearance > Theme: There are 3 Options. Bright UI, Dark UI (default) & Custom UI press Edit to change it. 
 

    
 

       
 
Window > General Settings > When Window is inactive: 100% (no opacity) – 75% – 50% and 25% Opacity.  
Window > General Settings > Start Refamo minimized state. 
Window > General Settings > Start Refamo Borderless. Note: Press (Ctrl+B) if you want to return with border view. 
Window > General Settings > Keep above other Windows 
Window > General Settings > Advanced (YOUR IP THAT REFAMO DETECTS WILL BE HERE)  

Note: Depending your LAN and the number of Nodes - Reducing too low the attempt duration and try again time 
Refamo might not be able to detect the Nodes. We do not suggest to change these settings-  unless you know what you 
are doing. If your IP above is not correct, please type inside the Override detected IP box: 
Window > General Settings > Advanced > Force failsafe connections (slow but sure) �� Failsafe node detection mode for 
networks that are heavily filtered or firewalled.  This mode avoids using UDP which makes it slower on Workstation OS machines such as XP, but if 
the node is accessible will connect no matter what. 
Window > �Override the detected IP/WINS address��� �����������	
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Note: Please check the Firewall Settings and Login Name and Pass on your Nodes. As the title says, Refamo will not 
respond in Full Speed but it is a safer method of detection. Please contact Ixor for troubleshooting.   
 
 
Properties:  Right Click (Group or Node Machine) > Properties 
 

 
 
 
RDP Login:  
�  Resolution: The most common resolutions are available. (640x480, 800x600, 1024x768, 1152x864 and 1280x1024) 
�  Color Depth: 8bpp, 16bpp and 24bpp is default. 
�  RDP Port: 3389 (Remote Desktop Protocol Port). You can change your port. Do not change it if you are not sure. 
�  Audio: Play Here, Play on remote, Do not play (default). 
 
Remote Login Credentials:  

Note: Please type carefully the exact default login details in order to be able to monitor the Node machines. 
Username: (necessary) 
Password: (necessary) 
Domain: (optional) 
 
Always Confirm: 
When you enable "Always confirm" a pop up window will appear when you ask Refamo to take these actions. 
�  VNC Login: This is an additional connection method. We recommend using RDP (default) since it is faster, but 

many users have already setup their network by using VNC. We have it there for you!   
�  Remote Command: Also known as CMD. Small pop-up window if you want to execute a remote command. For 

further information about CMD see page -6- of the manual. 
�  Wake on Lan: Refamo will ask for your approval for the Wake up signal. 
�  Restart: Refamo will ask you if you really want to restart the Machine(s).  
�  Shutdown: Refamo will ask you if you really want to turn-off the Machine(s).  
 
Ignore: 
�  Remote Command: The selected Group(s) and Machine(s) will not execute the CMD. 
�  Wake on Lan: The selected Group(s) and Machine(s) will not wake / turn-on. 
�  Restart: The selected Group(s) and Machine(s) will not reboot. 
�  Shutdown: The selected Group(s) and Machine(s) will turn-off. 
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Screen View: .  
Note: We do not suggest to change that setting. Refamo will perform faster when you request a Screen View. 

Especially if you are in a slow network connection. 

Energy Saving: ..is your friend! Turn it on!  
Note: The Energy Saving feature is a very good way for reducing your electricity bill, extend the life of your machines 
and, why not, protect our very valuable Earth!  

Note: The below examples are based on using a Renderfarm situation, but can be also applied to any kind of 
computational intensive project. 
 
Examples: 
For those related with 3D Images or Simulation effects, you know that a good result usually takes a lot of Rendering / 
Simulation time. Especially when we need to render animation sequences. People let their Renderfarm overnight to 
finish an animation or even an entire weekend. Others run simulations or other computational intensive works for days.  
In both cases, sometimes the Node(s) finish earlier than expected their task or due to wrong parameters or software 
bug, they experience a software crash, ending up with computers running without any reason for hrs or even days.  
 
 Refamo  Auto-detects when the CPU intensive process is finished and within minutes can specify the following 
scenarios: 
 
�  Shutdown:  After the specified period of time if the total CPU% load of each Node is below a certain % (that we 

have specified) then that Node(s) turns-off. 
�  Restart - recheck Shutdown if Idle: Like the Shutdown option but this time Refamo will reboot / restart the 

Machine(s) 1 time. For various reasons a Node might need a clean reboot to run the task. A common scenario is 
that after  several hrs the memory is full, so a reboot will help finish the job on time. 

�  Restart - recheck 2- 6 times:  
�  Restart - recheck - keep restarting when idle: This indeed does not sound like the most environmental friendly 

option! But we have it there since Refamo, will keep trying (no matter what) to finish your project on time. 
�  The CPU is below 1-100%: The default value is 50%. Here there is not a standard setting. But my suggestion is to 

set it lower < 20% . It all depends on the Node(s) CPU specifications and software running.  
For example, a Quad-Core system (CPU with 4 Cores) during a rendering process can use from 25%-100%. (Using 
only 1 core or all 4 Cores). Depending on the application you use (in our case Render Engine) you know if it is 
multi-threading (using all available CPU cores) or not. Below is a small guide: 
 
PC with 1 CPU: < 50%   PC with 2 CPU: < 40%   PC with 4 CPU: < 20%   PC with 8 CPU: < 12% 

PC with 16+ CPU:  ...if you have a System with 16Cores you know what you are doing.  
 
 
 
Short Cut List: 

 
Quit (Ctrl+Q) 
Remote Command (Ctrl+Shift+C) 
Wake (Ctrl+Shift+W) 
Restart (Ctrl+Shift+R)  
Shutdown (Ctrl+Shift+S) 
Delete (Ctrl+Shift+D) 
Show Graph Panel (Ctrl+G) 
Show Find Box (Ctrl+F) 
Auto Size Window (Ctrl+A) 
Display Borderless (Ctrl+B) 
Display Full Screen (Ctrl+Enter) 
 

 
Appearance - Theme - Bright (Ctrl+Shift+1) 
Appearance - Theme - Dark (Ctrl+Shift+2) 
Appearance - Theme - Custom (Ctrl+Shift+3) 
Appearance - Theme - Edit (Ctrl+Shift+T) 
Appearance - Opacity - 100% (Ctrl+1) 
Appearance - Opacity - 75% (Ctrl+2) 
Appearance - Opacity - 50% (Ctrl+3) 
Appearance - Opacity - 25% (Ctrl+4) 
Settings (Ctrl+S) 
About (Ctrl+Shift+A) 

 
 

For any kind of comments, errors or support please contact IXOR. 
4 Alevizatou Street, Papagou 156 69 Athens, Greece 

Tel: +30 210 6561958 Fax: +30 210 6561648 E-MAIL: info3d@ixor3d.com 


